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HINT: In order to facilitate reading this manual on your computer,
most concepts are presented on one “screen.” This symbol
appears if a concept or procedure spans more than one screen.
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Introduction
Blink© is a software program developed as free software under the terms of the
GNU General Public License as published by the Free Software Foundation.
This manual has been developed by the non-profit organization Volunteers for
Medical Engineering (www.vmesolutions.org).
Blink allows you to use a pointing device on your computer screen to select
letters, numbers, words, and phrases without the use of a keyboard. The
software is easily customized to allow you to create your own often-used words
and phrases so that you don’t need to re-enter the words each time you want to
express yourself.
Blink displays the text you enter. Blink also can say the text or E-mail it
through your existing E-mail account.
Blink has also been customized to work directly with an INSTEON network.
INSTEON is a Smarthome product that allows you to control electric devices
around your home, like lights, televisions, and radios, using the existing
electrical wiring and radio-frequency communications.

©

2008, 2009 Blink System, LLC. All Rights Reserved.
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Downloading the Blink Program
Before you can use Blink, you or a VME volunteer must install the Blink
software on your computer. You also need to have Java ™, version 6.0 or later,
installed on your computer.
The latest version of Blink can be found at: http://blinksystem.com
You can download Java from the Web site: http://java.com/en/download/index.jsp
To download Blink:
1. Open your browser and go the http://blinksystem.com
2. Download the Blink program and follow the instructions as they appear.
3. If you accept to have a shortcut installed on your computer, a Blink
icon will be placed on your desktop.

™

Java is a trademark of Sun Microsystems, Inc.
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Starting up the Blink Software
1.

To start up Blink simply click (you may have to double click) on the
Blink icon on your desktop.
If you did not have the installer program place a shortcut on your
desktop, but you allowed the software to be installed in the program files,
you can start up Blink by going to the Start menu, selecting Programs,
and then clicking on the Blink program.
Or, you can locate the folder on your computer called “Blink.” Double
click on the executable .jar file called blink.jar.

2.

It will take a couple of minutes for the Blink
program to load. You will see a small screen that
looks like the screen shown here.

3.

When the software is fully loaded on your
computer, the screen appears bigger and the “eye”
disappears.

4.

You are now ready to begin using Blink.
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Uninstalling the Blink Software
If you used the installer program to copy the Blink software onto your
computer, an uninstall program was also copied to the same location.
To uninstall Blink:
1.

Locate the Blink folder on your computer.

2.

In the Blink folder, you should find a folder call Uninstaller. If you
accepted the default location when you installed the software, it should
be in the following location on your computer: C:\Program
Files\Blink\Uninstaller.

3.

Click on the file called: uninstaller.jar.

4.

Follow the instructions on the screen.
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Understanding the Blink Screen
The Blink screen is separated into several sections as explained here.
Pull-down
Menus
Area where
your text
appears

Real-time
Clock

Quick Action
Bar For Often Used
Functions

Tabs –
You can add,
delete, and
reorder tabs

Suggestions –
Provides
suggested
words for your
composed text

Programmable
Keys – You can
change the
function, label,
and appearance
of these keys
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Compose Text
You can use Blink immediately to express yourself by using the Blink keyboard
that appears on the Keyboard tab. You do not need to program the keyboard
keys.
Click on the keyboard keys to compose a message. The message appears in the
“Compose Text” box.
Use the clear button in the Quick Action Bar to clear all the text in the
“Compose Text” box.
Use the delete word button in the Quick Action Bar to delete the last word
entered in the “Compose Text” box.
HINT: You can customize Blink so that often-used words and
phrases appear on the keys. This eliminates the need for you
to re-type words you use all the time.
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Say Text
Once you have composed text and it appears in the Compose Text box, press
the SAY button in the Quick Action Bar. The text will be “spoken” by the
computer.
HINT: The speaker in your computer must be on for the text to be heard.

Use Suggestions
You’ll notice when you select letters from the keyboard tab to compose text that
suggested words appear on the keys in the Suggestions box. These suggested
words appear based on the spelling of your most recently added text. Use them
to more easily compose your message.
The more you use Blink, the “smarter” these suggestions become. Words are
added and deleted from the Suggestions boxes based on the text you have
entered in the past.
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Customize Blink
Blink makes it easy to express often-used words or phrases, but first you must
customize, or program, some keys for your specific needs.
You can customize the keys in the Quick Action Bar. In addition, all of the
keys on any of the tabs can be customized. However, you probably won’t want
to change the keyboard keys. The top row of keys on the Keyboard tab is a
logical place for you to place phrases you repeat often. You can also add
additional tabs so that your ideas are logically grouped
To customize any of the keys or tabs, you need to switch from “Select” mode to
“Edit” mode. The Section “Change Modes” describes the mode options.
It’s important to remember that anytime you make a
customized change to your version of Blink, you must
save the file. After you reprogram or customize any
keys, pull down the file menu and click on the Save
option. If you want to save the changes as a separate
file, click on the Save As option and assign a new file
name to the Blink file. Use discretion when using the Save As file, since you
will now have multiple versions of Blink on your computer.

9

Change Modes
Blink has three “modes” or ways to operate. When you
start up Blink, you are in “Select” mode. You can
check the mode that you are in by pulling down the
Mode menu. The button will indicate the current
mode as shown here. To change the mode, click the
button next to the desired selection.
Select mode allows you to compose text or perform
the function for which a particular key has been programmed.
Edit mode allows you to customize any of the programmable keys. You can
also add or delete tabs in Edit mode.
HINT: The default Screen Preference mode is set so that Blink
starts up in Select mode. Directions on how to change this
preference are provided in the Section “Setting Screen Preferences.”

MORE
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Scan mode scrolls through the keys in a preset way. The scan highlights rows
from top to bottom, and then individual keys in that row from left to right.
To select a particular key while in scan mode, click on the row of the key you
want when it is highlighted. Then, click on the individual key when it is
highlighted. You can change the scan speed by pulling down the Edit menu
and going to Preferences, then Screen. The higher the Scan Speed the slower
the scan. Try 750 to slow the scan to a more comfortable pace if it is moving
too quickly.
If you don’t select a key, the scan stops automatically after it scans four times
vertically or twice horizontally.
HINT: Whenever you change a preference, you must press ENTER on
the computer’s keyboard while the cursor is in the changed field.
Then, press OK on the Preferences dialog box. If you don’t press
ENTER, your changes will not take effect.
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Setting Preferences – An Overview
You can change a few things about how Blink looks on your screen and how
several Blink features work. You do this by pulling down the Edit menu and
clicking on Preferences.
The Preferences window appears with options
to set preferences for the:





Screen
INSTEON Devices
Email
Javaspeech
MORE
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When you highlight one of the options on
the left-side of the Preferences window, the
screen changes. The preferences available
for the highlighted device appear. You can
reset these preferences to better suit your
needs.
Screen preferences are discussed in the
section “Setting Screen Preferences.”
Preferences for INSTEON devices are
discussed in the appendix “Setting up an
INSTEON Network.” Preferences for Email
are discussed in the section “Modifying
Blink Preferences for Email.” Javaspeech
is not currently discussed.
HINT: Press Return after changing each line in the Preferences window to
keep your changes during this session. When you are done changing your
preferences, pull down the File menu and click “Save.” This ensures your
changes are in effect the next time you open Blink.

13

Setting Screen Preferences
When the Screen device is
highlighted in the Preferences
window, you can change the
preferences as described in the
following table.

HINT: Double click in the Value column to change the setting.
Make sure to press Return, then OK to keep the changes for the
session. Go to File and click Save to save the changes for your
next session.

MORE
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Key

Description

Mode

When you open Blink, it starts in the mode set
here. You can still change the mode anytime
when using Blink.
The higher the Scan Speed the slower the
scan.

Scan_Speed

Show_Clock

You can either show or not show the clock in
the upper right corner of the screen. True
shows the clock. Leave the Value blank if you
don’t want the clock visible.
Show_Seconds You can either show or not show the second
hand on the clock. True shows the second
hand. Leave the Value blank if you don’t want
the second hand visible.
Theme
The theme sets the background colors and
contrast. Change the theme to suit your
needs. You can also change the Theme from
the Theme menu.

Values (Default
is Highlighted)
Select
Edit
Scan
750
Enter a value
between 100 and
750.
True
Leave entry
blank.
True
Leave entry
blank.
Ocean
Aqua
Charcoal
High Contrast
Emerald
Ruby
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Selecting a Theme
You can change the look of Blink by changing the theme. When you change
the theme, the background color of the screen changes. When you select the
Charcoal option, the color of the Compose Text box changes to black and the
text color changes to white.
To change a theme,
1.

Pull down the Themes menu.

2.

Click the button of the Theme you
want. The Blink screen changes
immediately.

3.

If you want to keep this theme for the next time you open Blink, pull
down the File menu and click Save.
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Basics of Programming Keys
To program a key, you must be in Edit mode. (See the Section “Change
Modes.”)
Click on the key you want to customize or program. The “Edit Cell” window
pops up. There are four tabs on this screen: Action, Color, Font, Icon.
The Action tab allows you to control the
function or action of the key. The other
three tabs control what the key looks like on
your screen.

Action Tab on the Edit Cell Screen
This window allows you to program the
function of the key. Fill in the information,
then press the OK button. Use the CANCEL
button to close the Edit Cell screen without
making any changes to the key.
Display Label – In the Display Label box
type the label you want to appear on the key. You’ll be able to change the size
and style of the lettering (font) from the “Font” tab.

MORE
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Device Name – The Device Name field is a pull-down box that allows you to either
send Email to a specific person or list, control an INSTEON device, control
JavaSpeech (this feature is not currently documented), or display text onto the
screen (Screen). Click on the “device” you want to control with this particular key.
Command – The options in the command pull-down menu change depending
on the device you are controlling with the key. Highlight the command you
want.
Data – The type of data you enter in this box is dependent upon the Device Name.
Use the table below to determine what kind of data is required in this field.
Device
Name Set to Text to be Entered in Data Box
Screen
Enter text that you want displayed in the Compose text box when the
key is pressed. (These may be your common words or phrases.)
Email
If you have a standard email you want to send, enter the text in the
data box (and do not check the “Fetch data from screen” box). The
text you enter into this box will be sent to the designated recipient(s)
whenever the key is pressed.

INSTEON
JavaSpeech

If you want to send an Email with text you compose in the Compose
Text box, do not enter text in this Data box. (In this case, check the
“Fetch data from screen” box.
Use the data box to enter the ID of the INSTEON device you want to
control with this key.
Not currently documented
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Color Tab on Edit Cell Screen
When you are in Edit mode and you click on
a key to program it, the Edit Cell window
appears. The Color tab allows you to change
the color of the key on your screen.
There are three ways to change the color:
Using swatches, HSB, or RGB colors. The
selected color shows in the Preview portion of
the window. There is a “Clear Selection”
button along the bottom edge of the window
that allows you to go back to the default color
(white) at any time. When you have made your selection, click OK to accept it.
Click CANCEL at anytime to close the Edit Cell window.
Swatches - Click on the swatch that matches your desired color.
HSB – HSB stands for the Hue, Saturation, and Brightness color model. You
can enter an HSB code into the H, S, and B boxes or click on the button next
to each letter, use the slider bar to select a color range and click in the color
box to make a selection.
RGB – RGB stands for the Red, Green, Blue color model. You can enter an
RGB code into the R, G, and B boxes, use the up/down arrows in each of the
boxes, or move the slider bars to select your desired color.
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Font Tab on Edit Cell Screen
When you are in Edit mode and you click on a key to program it, the Edit Cell
window appears. The Font tab allows you to change the style, size, and color of
the label on the key you are programming.
You can change the style of the
lettering, called the font, by
pulling down the list at the top
of the screen. The default font is
“Dialog,” so you may see that
font name in the pull-down
window. You will see the font
change at the bottom of the
window as you make changes.
Change the font size by either
typing in the new size or using
the up/down arrows. Again, the
font at the bottom of the window
will change as you make a new
selection.
Click in the Bold box to change to a heavier font. Click the Italics box to
italicize the font. Unclick the boxes to remove the feature.

MORE
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You can change the color of the font in the same way you change the color of
the key: Using swatches, HSB, or RGB colors. The selected color shows in the
Preview portion of the window.
There is a “Clear Selection” button along the bottom edge of the window that
allows you to go back to the default font (Dialog 12 point) at any time. When
you have made your selection, click OK to accept it. Click CANCEL at anytime
to close the Edit Cell window.
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Icon Tab on Edit Cell Screen
When you are in Edit mode and
you click on a key to program it,
the Edit Cell window appears. The
Icon tab allows you to select an
icon (picture) to appear as the label
on the key you are programming
instead of text.
Icons can be downloaded from any
reliable source.
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Programming Keys with Often-Used Words or Phrases – Practice
Session 1
If you have often-used words or phrases, you may want to “program” that text
on a key so that all you need is one click to communicate the information.
Let’s use the example that you like to move frequently between your recliner
and your wheelchair. Follow the steps below to program two keys so that you
can issue these requests more easily.
1.

Pull down the Mode menu and click on Edit. You are now in Edit mode.

2.

Click on the key you want to program. In this case, use one of the blank
keys on the Keyboard tab. The Edit Cell window appears.

3.

You will see the Action tab. We will make this key your request to move
to the recliner. So, in the Display Label box enter “Recliner”.

4.

In the Device Name box, select “Screen”.

5.

In the Command box, select “AddText”.

6.

In the Data box, enter the text that you want displayed when the key is
pressed. In this example, enter “I would like to move to my recliner,
please.”

7.

Make sure the box “Fetch data from screen” is unchecked.

8.

Click OK to accept the changes.

MORE
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9.

Click on the next key you want to program. This key will be your request
to move to your wheelchair.

10.

On the Action tab of the Edit Cell screen, enter “Wheelchair” into the
Display Label box.

11.

In the Device Name box, select “Screen”.

12.

In the Command box, select “AddText”.

13.

In the Data box, enter “I would like to move to my wheelchair, please.”
The box “Fetch data from screen” remains unchecked.

14.

Click OK to accept the changes.

MORE
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15.

You’ll notice when you return to the main screen that the word
“Wheelchair” is too long for the key. Let’s make the font smaller so the
lettering fits better and change the color of the key to make it more
visible.

16.

You are still in Edit mode, so click on the “Wheelchair” key.

17.

At the Edit Cell screen, click the “Color” tab. Make sure you are on the
Swatches tab and click on a color for the key.

18.

Click on the “Font” tab. Change the font style to “Arial” and the font size
to 10 point.

19.

Click OK to accept both changes.

20.

Now the word “Wheelchair fits on one line of the key and the key is more
noticeable because of the color change.

21.

Once you are satisfied with your changes to Blink, pull down the File
menu and click Save.

MORE
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Let’s test that the keys are working correctly.
1.

Pull down the Mode menu and click on “Select”. You are now in Select
mode.

2.

Click “clear” in the Quick Action Bar to clear all text from the Compose
Text box.

3.

Click on the “Recliner” key. The phrase “I would like to move to my
recliner, please.” should appear in the Compose text box.

4.

Click “clear” in the Quick Action Bar to clear that phrase from the
Compose Text box.

5.

Click on the “Wheelchair” key. The phrase “I would like to move to my
wheelchair, please.” should appear in the Compose text box.

6.

To have the computer speak the words, click on “Say” in the Quick
Action Bar. Your computer speaker must be on and the volume up for
the sound to be audible. The text disappears from the Compose Text box
when the phrase is spoken.
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Programming Keys for Computer Functions – Practice Session 2
You may want to “program”
computer and keyboard
functions so they are
available from several tabs.
The following commands
can be set from the Edit
Cell window when the
“Screen” device is selected:












Add text
Add Word
Backspace
Clear
Delete word
Go To Tab
Prev Tab
Next Tab
Scan faster
Scan slower
Space
MORE
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Follow the steps below to program a Backspace key so that you can delete one
letter at a time in the Compose Text box.
1.

Pull down the Mode menu and click on Edit. You are now in Edit mode.

2.

Click on the key you want to program. In this case, use one of the blank
keys on the Keyboard tab. The Edit Cell window appears.

3.

You will see the Action tab. In the Display Label box enter “Backspace”.

4.

In the Device Name box, select “Screen”.

5.

In the Command box, select “Backspace”.

6.

You do not need to enter anything into the Data box.

7.

Make sure the box “Fetch data from screen” is unchecked.

8.

Click OK to accept the changes.

9.

Once you are satisfied with your changes to Blink, pull down the File
menu and click Save.

MORE

HINT: You may want to program keys for the Scanfaster and Scanslower functions.
The more you use the scan function, the more adept you will become with the
timing. You can change the scan speed through the “Edit > Preferences > Screen
menus, but to change the speed more easily, program keys for this function.
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Let’s test that the backspace key is working correctly.
1.

Pull down the Mode menu and click on “Select”. You are now in Select
mode.

2.

Click “clear” in the Quick Action Bar to clear all text from the Compose
Text box.

3.

Click on the “Recliner” key (programmed in Practice Session 1). The
phrase “I would like to move to my recliner, please.” should appear in the
Compose text box.

4.

Click the “Backspace” key. The period at the end of the sentence is
erased.

5.

Click the “Backspace key again. The “e” at the end of “please” is erased.
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Creating, Deleting, and Editing Tabs
You can create or delete tabs to help organize your ideas or tasks. For
example, you may want to keep the Keyboard tab simple with just letters and
numbers. You can then put keys pre-programmed with expressions or phrases
on a separate tab, keys to send E-mail on another tab, and keys to control
INSTEON devices on yet another tab.
You can also delete a tab and all the keys associated with it or rearrange the
order of the tabs on your screen.

30

Creating a New Tab
When you create a new tab, you have the ability to control the size of the keys
displayed on that tab.
You can be in either Edit mode or Select mode to
create a new tab.
To create a new tab,
1.

Pull down the Edit menu.

2.

Select New Tab. A Set Tab Defaults window appears.

3.

Enter the title for the Tab.

4.

Enter the number of rows and columns you want for
keys on this tab. You can either type in the number
or use the up / down arrows next to the box to select
the desired number. A tab with three rows and five
columns provides much bigger keys and makes it
easier to read the key labels.

5.

Click OK. Your new tab appears as the last tab on the right.

HINT: You can
change the Tab
title at any time
while in Edit
mode by
clicking on the
Pencil icon.

HINT: Remember to pull down the File menu and click Save to
permanently save all customizations you’ve made to the Blink software.
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Moving Between Tabs
You can move between tabs when you are in any mode.
To move between tabs:


When in Select mode, click on the tab title.



When in Edit mode, click on the tab title. Do not click the symbols (



When in Scan mode, click on the PREV or NEXT keys in the Quick Action
Bar. You may decide to program a PREV and NEXT key on each of your
tabs.

).
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Rearranging Tabs
You can change the order of the tabs as they are displayed in Blink. To change
the tab order, you must be in Edit mode.
To change the order of a tab, click on the tab you want to re-order and drag it
to its new location. You will see the “shadow” move as you drag the tab.
HINT: Think of the tabs as file folders. You can only
relocate a tab within the Commands box. You cannot
move it anywhere else on the Blink screen.
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Editing Tabs
You must be in Edit mode to edit
a tab. When you are in edit mode, you’ll notice symbols on the tabs. The
symbols are described in the following table.
Symbol

Function
Click on the pencil to write over the name of the tab.
Click on the checkmark to accept the new tab name.
Click on the export tab icon to export the tab. Read more about
exporting a tab in the “Exporting Tabs” section.
Click on the red x to delete the tab.

HINT: Don’t worry if you delete a tab accidentally. Your changes are not
saved in Blink until you pull down the File menu and select save.
Therefore, if you delete a tab that you wanted to save, just close Blink
and re-open it. Your tab will be restored. However in this case, any
other changes you made without saving will be lost.
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Exporting Tabs
Blink allows you to share tabs by exporting and importing them. When you
export a tab, you save it on your computer as a file with an .xml extension.
To export a tab,
1.

Pull down the Mode menu and click Edit to enter Edit mode.

2.

Click on the

3.

Pull down the “Look in” menu and select the drive location on your
computer where you would like to store the file.

4.

Highlight the folder where you would like to store the file.

5.

Enter a file name in the File Name box.

6.

Click the Export Tab button. The file will be saved in the location you’ve
designated as: filename.xml

icon for the tab you want to export.

HINT: If you’ve received exported tabs from other users, you can import
those tabs. Follow the procedure in the “Importing Tabs” section.
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Importing Tabs
Other people may create tabs for you to use with your Blink software. For
example, your teacher may want to create unique tabs that allow you to submit
responses for specific lessons. Or you may want to move a tab to a copy of
Blink on a different computer.
You can be in either Select or Edit mode to import a tab.
To import a tab,
1.

Pull down the Edit menu and click Import Tab.

2.

Locate the .xml file that you want to
import. Pull down the “Look in” menu and
select the drive location on your computer,
then select the folder where you stored the
file when you received it.

3.

Highlight the .xml file name of the tab you
want to import. The file name appears in
the File Name box.

4.

Click the Import Tab button. The tab appears on your Blink screen.

5.

If you want to save the changes you made to Blink, pull down the File
menu and click Save.
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Adding an INSTEON Tab – Practice Session 3
If you will be using several INSTEON devices with Blink, add a new tab to
group the keys that will be controlling those devices.
1.

Pull down the Edit menu.

2.

Select New Tab. A Set Tab Defaults window appears.

3.

In the Tab Name box, enter INSTEON.

4.

For this example, let’s say that you
have six INSTEON devices you wish to
control. You can create a tab with only
six keys. This will give you plenty of
room for a label and make it easier to
click on the key. In the Rows box,
enter 2. In the Columns box, enter 3.

5.

Click OK. Your new tab will appear as the last tab on the right.

6.

Once you are satisfied with your changes to Blink, pull down the File
menu and click Save.
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Programming a Key for an INSTEON Device
Blink has been created to work directly with your INSTEON devices. First, you
or a VME volunteer must set up an EZSrve Gateway. Instructions for this set
up are included in Appendix A. Second, you must program a key to correlate
the function you want (Lamp ON) with a specific INSTEON device. You must be
in Edit mode to program a key.
You can control the following functions for INSTEON devices:







All ON (For multiple devices)
All OFF (For multiple devices)
Bright
Dim
ON (For one device)
OFF (For one device)

HINT: Change the color and font on
the key to easily identify the
function. For example, all ON
function keys can be green; all OFF
function keys can be red. Or change
the color of text so that all controls
for TV have blue key labels.

You may want to organize your Blink screen so that all your INSTEON devices
are controlled by keys on an INSTEON tab (as suggested in Practice Session 3),
or you may want to customize the keys in the Quick Action Bar to control your
INSTEON devices.
MORE
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To program a key to control an INSTEON device:
1.

Enter Edit mode by pulling down the Mode menu and clicking on Edit.

2.

Click on the key that you want to program.

3.

The Edit Cell window appears. In the Display Label box, enter the label
for the key. Use a descriptive term, such as “Kitchen Light ON” so it is
clear which device you are controlling.

4.

In the Device Name box, select INSTEON.

5.

In the Command box, select the function you want this key to perform.

6.

In the Data box, type the “address” of the INSTEON device you want to
control. The address is printed on the INSTEON module into which you
plugged the device.

7.

The “Fetch data from screen” box remains unchecked.

8.

Click OK.

9.

Once you are satisfied with your changes to Blink, pull down the File
menu and click Save.
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Sending Email Directly from Blink – An Overview
Blink allows you to send text from the Compose Text box to pre-specified Email
accounts. Or, you can send a pre-defined message to recipients with just the
click of a key. You can designate up to ten Email recipients or groups.
You must take several steps to set up Blink for Email:
1.

You have to modify Blink Preferences to specify your host outgoing Email
server and your Email username and password.

2.

You have to modify Blink Preferences to identify Email recipients. You
can identify up to ten distinct recipients. A “recipient” can actually be a
list of several email addresses if you want the same message to be sent to
multiple people. Or, a “recipient” can be an address for a phone capable
of receiving an Email message.

3.

You have to customize a key so that whatever text is in the Compose
Text box can be retrieved and Emailed to the designated Email recipient
or recipients. Or, you can enter a pre-determined message that will be
delivered each time you press the key.

4.

Once all of that is set up, you can send your message as Email with just
the push of one key.
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Modifying Blink Preferences for Email
In order to send text directly from Blink via Email, Blink needs to be able to
identify and authenticate your Email account. You will only need to configure
Blink with your own Email server information one time (unless you change
your Email account).
Your Email must be able to support a POP client. Therefore, web-based mail
servers may or may not to work with Blink. Hotmail (Microsoft) does not work
well with Blink, however, Gmail (Google) does work directly with Blink.
HINT: Before beginning, make a written list of the
Email addresses that you want to identify as
Email recipients in Blink.
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Set up the Blink Preferences for Email as follows:
1.

Pull down the Edit menu and click on Preferences.

2.

When the Preferences window appears,
click on Email to see the available
preferences for the Email functions.

3.

AUTH field: Do not change the default
value “true”. The Email server needs to
authenticate your Email address and
password.

4.

FROM field: Enter your complete Email
address (user@gmail.com). This is the
address from which the Email will be sent.

5.

HOST field: Enter the identifier for the
outgoing mail server you are using. You can usually find this
information on the Website for your Email company. For example, the
outgoing mail server for gmail is: smtp.gmail.com. The outgoing mail
server for Comcast is: smtp.comcast.net.

HINT: Press Return after changing each line in the Preferences
window to keep your changes during this session. In order to
save your changes for the next time you open Blink, pull down
the File menu and click “Save” when done with this procedure.
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6.

LOGIN field: Enter your personal Email login / username. Most likely,
this is your Email address.

7.

PASSWORD field: Enter your personal Email password. This field is
case sensitive so be sure to use the correct case when entering your
information.

8.

SUBJECT field: Enter text that you want for a subject line in the Email.
This text will be used for ALL Email sent from Blink.

9.

User_1 through User_10 fields: Enter the Email address for the
intended recipients. One User entry can actually contain several Email
addresses, with each address separated by a comma, so that you can
send the same Email to multiple recipients. You can also enter an Email
address in this field for an Email-enabled phone (for example,
4109999999@messaging.sprintpcs.com).

10.

Use_SSL field: Do not change the default value
“true”. This field encrypts and protects your
Email account.

11.

When you have finished changing the Preference
window for Email, press the OK button. Then,
pull down the File menu and save your file so
that the changes will still be in effect the next
time you open Blink.
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Two Ways to Use the Email Function
Once you have properly set up your Preferences window to support Email, you
can program a key to send the Email. You can actually use the Email function
in two different ways.
1.

You can enter a unique message in the Compose Text box that you want
to send to one of the recipients you specified in the Preferences window.

2.

You can enter a standard message that will always be delivered to one of
the recipients you specified in the Preference window.
HINT: A recipient can actually be a list of several Email addresses.
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Programming a Key to Send a Unique Email Message
1.

Enter Edit mode by pulling down the Mode menu and clicking on Edit.

2.

Click on the key that you want to program.

3.

The Edit Cell window appears. In
the Display Label box, enter the
label for the key. Use a descriptive
term such as “Email to Bitzy.”

4.

In the Device Name box, select
Email.

5.

In the Command box, select the
recipient (or the line with a list of
recipients) to whom the Email will
be sent when the key is pressed.

6.

Leave the Data box empty.

7.

Check the “Fetch data from screen” box. Checking this box means that
whatever text is entered in the Compose Text box when the key is
pressed will become the Email message that is delivered.

8.

Click OK.

9.

Once you are satisfied with your changes to Blink, pull down the File
menu and click Save.
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Programming a Key to Send a Standard Email Message
1.

Enter Edit mode by pulling down the Mode menu and clicking on Edit.

2.

Click on the key that you want to program.

3.

The Edit Cell window appears. In the Display Label box, enter the label
for the key. Use a descriptive term such as “I’m Home Email.”

4.

In the Device Name box, select Email.

5.

In the Command box, select the recipient (or the line with a list of
recipients) to whom the Email will be sent when the key is pressed.
MORE
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6.

In the Data box, type
the message that will
ALWAYS be delivered
as the Email message
when the key is
pressed.

7.

Do not check the
“Fetch data from
screen” box. Text that
is in the Compose Text
box will not be sent as
part of this Email.

8.

Click OK.

9.

Once you are satisfied
with your changes to
Blink, pull down the
File menu and click
Save.
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Sending a Unique Email Message
To send a unique Email message, you must have properly set up your Email
preferences and programmed the key. Refer to the sections “Modifying Blink
Preferences for Email” and “Programming a Key to Send a Unique Email Message.”
With that accomplished, it is easy to
compose and send the message.
1.

Make sure you are in Select or
Scan mode.

2.

Compose your message by
clicking on the keys on any of
the Blink tabs or the
“Suggestions” keys. Your
message will appear in the
“Compose Text” box.
3. Click on the key you
programmed to send the Email
to the desired recipient.
4. Notice the status message at
the bottom of the screen. This
message will confirm that the Email was sent to the desired recipient.
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Sending a Standard Email Message
To send a standard Email message, you must have properly set up your Email
preferences and programmed the key. Refer to the sections “Modifying Blink
Preferences for Email” and “Programming a Key to Send a Standard Email Message.”
With that accomplished, it is easy
to send the message.
1.

Make sure you are in Select
or Scan mode.

2.

Click on the key you
programmed to send the
same Email message to the
desired recipient. You do
not need to enter any text
into the “Compose Text” box,
since your standard message
was already entered in the
Data box when you
programmed the key.

3.

Notice the status message at
the bottom of the screen.
This message will confirm that the Email was sent to the desired recipient.
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Appendix : Setting Up an INSTEON Network
To set up Blink to work with INSTEON (or X10) devices, you first need to
establish an EZSrve INSTEON / X10 Home Automation Gateway. (This
hardware is available from www.Smarthome.com). This small stand-alone
device establishes the EZSrve Gateway between your PC network and the
electrical wiring. A web server, integral to the EZSrve Gateway module, allows
you to set up the device using an available IP address from your router. Each
appliance that is to be controlled through the Gateway plugs into its own
appliance module allowing it to be controlled individually from Blink. The
device ID for each appliance module is specified when the Blink key is
programmed for operation.
For installation and set up of the EZSrve Gateway, follow the instructions
provided with the hardware. From the EZSrve web server interface, set a static
IP address for the home automation (INSTEON) network. Use an address that
isn't currently used at the network location.
MORE
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Enter the network IP address for the EZSrve Gateway into Blink:
1.

Pull down the Edit menu.

2.

Click on Preferences.

3.

Click on the INSTEON option on the left side of the screen.

4.

Change the default setting for the IP address by double clicking on the
setting in the Value column. Enter the IP address for the EZSrve
Gateway.

5.

Press return to commit the value.

6.

Double click on the Port id. Enter the port id of the Gateway. Refer to
the EZSrve Gateway documentation.

7.

Press return to commit the value.

8.

Press OK to close the window.

9.

Once you are satisfied with the changes, pull down the File menu and
select Save.

